Helpful ReplyHot!Cant stop FortiClient from starting on startup

Author
JonStarr
New Member
  • Total Posts : 1
  • Scores: 0
  • Reward points: 0
  • Joined: 2013/05/16 18:49:20
  • Status: offline
2013/05/16 18:54:42 (permalink)
0

Cant stop FortiClient from starting on startup

I' m using FortiClient for VPN purposes only and dont need it running any other time. I cant get disable fortinet from starting on startup. Its getting very frustrating.

I' ve followed this guide;
http://kb.fortinet.com/kb/microsites/search.do?cmd=displayKC&docType=kc&externalId=FD31776
 
But when I go to step 2 and try to uncheck FortiClient Service Scheduler and click Apply, it automatically re-ticks itself.

Anyone had this problem or know how to solve it? We use Forticlient for corporate vpn and I' m having second thoughts now.
#1
AtiT
Platinum Member
  • Total Posts : 479
  • Scores: 42
  • Reward points: 0
  • Joined: 2012/04/18 12:13:27
  • Location: Prague / Czech Republic
  • Status: offline
RE: Cant stop FortiClient from starting on startup 2013/05/16 21:39:58 (permalink) ☄ Helpfulby lenci 2017/01/10 00:36:24
5 (3)
Hi,
I have the newest version of FortiClient installed 5.0.3 on Windows 8 x64bit and this worked for me.

1) Right-click on the FortiClient icon on the taskbar and select Shutdown FortiClient.
2) go to command prompt and enter: net stop fortishield [ENTER]
3) RUN -> msconfig and go to services tab. Uncheck the service FortiClient Service Scheduler and [APPLY] - Do not restart the PC now.
4) RUN -> services and search for FortiClient Service Scheduler. Right-click -> Properties and change the startup type to: Manual.
5) Reboot

It also worked on Win 7 32bit.

Regards,
< Message edited by AtiT -- 5/17/2013 7:23:24 AM >

AtiT
--------------------
NSE 8, CCNP R+S
#2
thronk
New Member
  • Total Posts : 1
  • Scores: 0
  • Reward points: 0
  • Joined: 2016/03/09 11:57:58
  • Status: offline
Re: RE: Cant stop FortiClient from starting on startup 2016/03/09 11:59:39 (permalink)
0
AtiT
Hi,
I have the newest version of FortiClient installed 5.0.3 on Windows 8 x64bit and this worked for me.

1) Right-click on the FortiClient icon on the taskbar and select Shutdown FortiClient.
2) go to command prompt and enter: net stop fortishield [ENTER]
3) RUN -> msconfig and go to services tab. Uncheck the service FortiClient Service Scheduler and [APPLY] - Do not restart the PC now.
4) RUN -> services and search for FortiClient Service Scheduler. Right-click -> Properties and change the startup type to: Manual.
5) Reboot

It also worked on Win 7 32bit.

Regards,



Thank you so much, I was JUST dealing with this on my PC.  Had to add it for a managed client who has a Fortinet firewall and now I couldn't get it to disable the startup of the service (Invalid Parameter) it kept saying.  This did the trick beautifully!
#3
lenci
New Member
  • Total Posts : 1
  • Scores: 0
  • Reward points: 0
  • Joined: 2016/10/26 00:31:03
  • Status: offline
Re: RE: Cant stop FortiClient from starting on startup 2017/01/10 00:38:54 (permalink)
0
AtiT
Hi,
I have the newest version of FortiClient installed 5.0.3 on Windows 8 x64bit and this worked for me.

1) Right-click on the FortiClient icon on the taskbar and select Shutdown FortiClient.
2) go to command prompt and enter: net stop fortishield [ENTER]
3) RUN -> msconfig and go to services tab. Uncheck the service FortiClient Service Scheduler and [APPLY] - Do not restart the PC now.
4) RUN -> services and search for FortiClient Service Scheduler. Right-click -> Properties and change the startup type to: Manual.
5) Reboot

It also worked on Win 7 32bit.

Regards,

Thanks! This helped.
#4
ChrisFGT
New Member
  • Total Posts : 2
  • Scores: 2
  • Reward points: 0
  • Joined: 2018/02/24 09:36:31
  • Status: offline
Re: RE: Cant stop FortiClient from starting on startup 2018/03/13 16:03:14 (permalink) ☄ Helpfulby jdgarcia1381 2021/01/29 18:29:54
5 (1)
Here's how to disable FortiClient daemon automatic startup on a Mac:

Tested on:
macOS 10.13.3, FortiClient 5.6.6
 
Reference materials:
FortiClient Administration Guide
FortiClient XML Reference Guide
launchd tutorial
 
System changes made:
 
/Library/LaunchAgents/com.fortinet.forticlient.credential_store.plist
Change RunAtLoad key from true to false, and add false parameter below KeepAlive key...
        <key>RunAtLoad</key>
        <false/>
        <key>KeepAlive</key>
        <false/>

/Library/LaunchAgents/com.fortinet.forticlient.fct_launcher.plist
Change RunAtLoad key from true to false...
        <key>RunAtLoad</key>
        <false/>
 
A before/after comparison of running processes after reboot will demonstrate successful changes:
 
Before, with FortiClient auto-started (with leading columns cut out for ease of display)...
$ ps aux | grep -i forti | cut -d \/ -f2-
Library/Application Support/Fortinet/FortiClient/bin/fctappfw
Applications/FortiClient.app/Contents/Resources/runtime.helper/FortiClientAgent.app/Contents/Resources/runtime.helper/FctMiscAgent.app/Contents/MacOS/FctMiscAgent
Library/Application Support/Fortinet/FortiClient/bin/epctrl
Library/Application Support/Fortinet/FortiClient/bin/ftgdagent
Library/Application Support/Fortinet/FortiClient/bin/fctservctl
Applications/FortiClient.app/Contents/Resources/runtime.helper/FortiClientAgent.app/Contents/MacOS/FortiClientAgent
Library/Application Support/Fortinet/FortiClient/bin/CredentialStore
$
 
After reboot, the same grep should return zero process results (other than your grep process), and the tray icon will no longer be loaded.
$ ps aux | grep -i forti
$
 
post edited by ChrisFGT - 2018/03/16 08:55:10
#5
aleckgt
New Member
  • Total Posts : 1
  • Scores: 0
  • Reward points: 0
  • Joined: 2019/07/13 10:39:28
  • Status: offline
Re: RE: Cant stop FortiClient from starting on startup 2019/07/13 10:48:28 (permalink)
0
1. You should also modify the file com.fortinet.forticlient.fct_launcher.plist
 
<key>RunAtLoad</key>
<false/>
 
Thanks very much for your help!
#6
mcooper
New Member
  • Total Posts : 2
  • Scores: 0
  • Reward points: 0
  • Joined: 2020/05/22 07:36:01
  • Status: offline
Re: RE: Cant stop FortiClient from starting on startup 2020/05/22 07:37:20 (permalink)
0
I have FortiClient VPN on Windows 10. When I (after shutting down the software) run Windows PowerShell as administrator and type net stop foritshield, all I get is this:
 
The service name is invalid.
 
Any tips?
#7
NetworkIP Technology
New Member
  • Total Posts : 2
  • Scores: 0
  • Reward points: 0
  • Joined: 2020/05/14 12:41:42
  • Status: offline
Re: Cant stop FortiClient from starting on startup 2020/05/23 20:05:44 (permalink)
0
you have to stop forticlient to start with windows. just go to : Control Panel\All Control Panel Items\Administrative Tools\System Configuration\Startup and unselect  schedule vpn client.
#8
mcooper
New Member
  • Total Posts : 2
  • Scores: 0
  • Reward points: 0
  • Joined: 2020/05/22 07:36:01
  • Status: offline
Re: Cant stop FortiClient from starting on startup 2020/05/24 17:53:38 (permalink)
0
I'm afraid it isn't listed there...
#9
gr8jam
New Member
  • Total Posts : 1
  • Scores: 2
  • Reward points: 0
  • Joined: 2020/11/05 12:45:09
  • Status: offline
Re: Cant stop FortiClient from starting on startup 2020/11/05 12:54:37 (permalink)
5 (1)
I found a way to disable auto start in Linux. Sudo rights are needed.
To shutdown FortiClient:
systemctl stop forticlient-scheduler

To disable the auto start at the next boot:
systemctl disable forticlient-scheduler

 
post edited by gr8jam - 2020/11/05 12:55:41
#10
anderson.pa
New Member
  • Total Posts : 1
  • Scores: 0
  • Reward points: 0
  • Joined: 2020/12/06 09:03:09
  • Status: offline
Re: Cant stop FortiClient from starting on startup 2020/12/06 09:15:39 (permalink)
0
thanks gr8jam, exactly what I was looking for.
 
I'm just using forticlient to vpn into work for occasional remote monitoring and don't expect to use it all that frequently. If anybody from Fortinet is reading, this sort of behavior from software is truly obnoxious and arrogant. Please don't assume users need or want your software running all the time. At a minimum, there should be an easy way to disable this from the GUI settings page. Better would be to additionally ask for permission first. I shouldn't have to waste 30 minutes tracking down an answer in the forums, or worse have to dig out the commands on my own if somebody else hadn't already done it.
#11
Jump to:
© 2021 APG vNext Commercial Version 5.5