Unable to resolve hostname

Author
wilson19
New Member
  • Total Posts : 2
  • Scores: 0
  • Reward points: 0
  • Joined: 2019/12/27 11:17:20
  • Status: offline
2020/03/25 04:22:08 (permalink)
0

Unable to resolve hostname

I'm having trouble getting one of my Fortigate 200Es to be able to resolve hostnames.
 
If the system DNS servers are set to use the Fortinet servers (or any other external DNS servers), I'm unable to resolve any host names.
 
If I set the system DNS servers to our internal ones, I can resolve the host names but PING still fails.
 
Any ideas what I should check to get this resolved?
 
Thanks,
Wilson
#1

2 Replies Related Threads

    rwpatterson
    Expert Member
    • Total Posts : 8466
    • Scores: 201
    • Reward points: 0
    • Joined: 2006/08/08 10:08:18
    • Location: Long Island, New York, USA
    • Status: online
    Re: Unable to resolve hostname 2020/03/25 06:17:28 (permalink)
    0
    You have two different issues. Using your own DNS solved the resolution issue. Next is the reachability. Do you have a policy from A-B with ICMP enabled? (or 'ANY')

    -Bob - self proclaimed posting junkie!
    See my Fortigate related scripts at: http://fortigate.camerabob.com

    -4.3.19-b0694
    FWF60B
    FWF80CM (4)
    FWF81CM (2)
     
    #2
    TecnetRuss
    Bronze Member
    • Total Posts : 22
    • Scores: 8
    • Reward points: 0
    • Joined: 2017/02/27 13:14:44
    • Status: offline
    Re: Unable to resolve hostname 2020/03/25 17:40:25 (permalink)
    0
    Are you trying to ping the short name (e.g. server1) or the long name/FQDN (e.g. server1.domain.local)?
     
    If you're only having trouble with short name resolution keep in mind that short names will only resolve if you have correct default DNS suffix configured.
     
    On the FortiGate itself this is set under Network / DNS in the Local Domain Name field right below where you've set your internal DNS server IP addresses.
     
    If you're finding that VPN clients can't resolve internal server names (short names) properly and network drives don't map correctly, etc. even with your internal DNS servers set correctly in the IPSec or SSL-VPN tunnel configuration, check that the DNS suffix is set correctly as follows:
    • If you're using IPSec Remote Access:

      config vpn ipsec phase1-interface
      show
      edit <VPN-dial-up-interface-name>
      set domain <internal-domain-suffix> (e.g. domain.local)
      end
    • If you're using SSL-VPN Remote Access:

      config vpn ssl settings
      set dns-suffix <internal-domain-suffix> (e.g. domain.local)
      end
    Russ
    NSE7
    #3
    Jump to:
    © 2020 APG vNext Commercial Version 5.5