Hot!DHCP not work

Author
papapuff
Silver Member
  • Total Posts : 68
  • Scores: 0
  • Reward points: 0
  • Joined: 2012/05/24 20:31:44
  • Status: offline
2014/09/26 03:18:43 (permalink)
0

DHCP not work

hi there,

need help please.

we use FG 100D. I have set for the interface 1 as a dhcp server (thicked), declare IP range for dhcp. here summary setup:
IP for Interface 1 = 192.168.1.1
secondary ip addres = 192.168.100.1
DHCP range: 192.168.100.2 - 192.168.100.5

then I save. I try to client, but client can' t get auto IP.

need help. thanks.
#1

14 Replies Related Threads

    papapuff
    Silver Member
    • Total Posts : 68
    • Scores: 0
    • Reward points: 0
    • Joined: 2012/05/24 20:31:44
    • Status: offline
    RE: DHCP not work 2014/09/28 18:51:33 (permalink)
    0
    Hello there,

    need help here please
    #2
    neonbit
    Gold Member
    • Total Posts : 381
    • Scores: 26
    • Reward points: 0
    • Joined: 2013/07/02 21:39:52
    • Location: Dark side of the moon
    • Status: offline
    RE: DHCP not work 2014/09/28 19:24:08 (permalink)
    0
    Hi papapuff,

    I' m not sure if what you want to do is possible.

    When you configure the address range of the DHCP server it needs to be in the same subnet as the interface, not the secondary IP address.

    When I try this out in my lab I can see the FortiGate warning me about this.

    Attached Image(s)

    #3
    Dave Hall
    Expert Member
    • Total Posts : 1207
    • Scores: 112
    • Reward points: 0
    • Joined: 2012/05/11 07:55:58
    • Location: Canada
    • Status: offline
    RE: DHCP not work 2014/09/28 20:28:08 (permalink)
    0
    I agree with Neonbit -- not sure what papapuff is trying to accomplish with trying to create a dhcp pool on a different subnet to the Interface, unless he is trying to set up
    some sort of NAT loopback or NAT hairpinning.

    FCNSA /FMG-VM64/FortiAnalyzer-VM/4.0 MR3P18 5.0.9 (FWF40C/FWF80CM/FGT200B/FGT200D) / FAP220B/221C
    #4
    papapuff
    Silver Member
    • Total Posts : 68
    • Scores: 0
    • Reward points: 0
    • Joined: 2012/05/24 20:31:44
    • Status: offline
    RE: DHCP not work 2014/09/28 20:38:54 (permalink)
    0
    hi,
    thanks for reply.
    why I don' t see any warning on my FG? and can be saved.
    FW version is 5.02

    thanks
    #5
    neonbit
    Gold Member
    • Total Posts : 381
    • Scores: 26
    • Reward points: 0
    • Joined: 2013/07/02 21:39:52
    • Location: Dark side of the moon
    • Status: offline
    RE: DHCP not work 2014/09/28 21:12:18 (permalink)
    0
    I' m guessing that the check feature was added on the newer versions.

    I' m running 5.2.1 (the latest version), I' m not sure if your 5.02 means 5.2.0 or 5.0.2, if it' s 5.0.2 I would recommend upgrading at least to 5.0.7 (preferably to 5.0.9) since it fixes the heart bleed vulnerability.

    Or live life in the fast lane and goto 5.2.1 :)
    #6
    papapuff
    Silver Member
    • Total Posts : 68
    • Scores: 0
    • Reward points: 0
    • Joined: 2012/05/24 20:31:44
    • Status: offline
    RE: DHCP not work 2014/09/28 23:21:06 (permalink)
    0
    hi, the version is:
    FG100D-5.00-build252

    thank you.

    #7
    papapuff
    Silver Member
    • Total Posts : 68
    • Scores: 0
    • Reward points: 0
    • Joined: 2012/05/24 20:31:44
    • Status: offline
    RE: DHCP not work 2014/09/29 00:36:54 (permalink)
    0
    I think DHCP works only to main IP, as you told before. :D

    for security reason, which one is better:
    option 1.
    I use 2 interface, 1 interface for dhcp so guests/public devices can access internet over DHCP without interrupt internal network.

    option 2, use 1 interface, with main IP is for DHCP (so public devices will use this IP segment), and secondary IP is for internal network.
    thank you
    < Message edited by papapuff -- 9/29/2014 12:56:50 AM >
    #8
    neonbit
    Gold Member
    • Total Posts : 381
    • Scores: 26
    • Reward points: 0
    • Joined: 2013/07/02 21:39:52
    • Location: Dark side of the moon
    • Status: offline
    RE: DHCP not work 2014/09/29 16:10:11 (permalink)
    0
    Since we haven' t got a network diagram and the network requirement it' s a little hard to confirm the best approach, but if it' s possible to put the guest/public users on a different interface I would definitely recommend that. Separate them physically and logically from your internal network whenever possible.

    This way you would have a policy from guest > wan, and a policy from trust > wan. It will make it much easier to track usage and control policies.

    Also you' re currently running 5.0.5, this is vulnerable to heartbleed. I would recommend you look into upgrading the device to 5.0.7 at a minimum (with 5.0.9 more ideal). You can upgrade the device to 5.0.7 directly, but will require it to be 5.0.7 before going to 5.0.9. The 5.0.9 release notes can be found here: http://docs.fortinet.com/d/fortios-5.0.9-release-notes
    #9
    papapuff
    Silver Member
    • Total Posts : 68
    • Scores: 0
    • Reward points: 0
    • Joined: 2012/05/24 20:31:44
    • Status: offline
    RE: DHCP not work 2014/09/30 02:16:12 (permalink)
    0
    hi,
    suddenly dhcp not work. clients can get IP from DHCP.
    now I set some ports into LAN (not as interface), and enable dhcp on that interface (LAN).

    is the FG auto-update? if I do upgrade, do I need to re-setup again? vpn, policy and so on?

    thanks.
    #10
    Aury
    New Member
    • Total Posts : 1
    • Scores: 0
    • Reward points: 0
    • Joined: 2014/10/06 07:44:58
    • Status: offline
    DHCP not work -stay in Obtain IP-- 2014/10/06 07:47:39 (permalink)
    0
    Hello,
    I need help urgently, currently DHCP option is activated on Fortigate 310B, however, none of the client machines are able to obtain an IP address, thus failing to connect entirely. This ocurred before and rebooting the Fortigate fixed it, but last time, after rebooting, the service was completely down on the Fortigate.
    #11
    papapuff
    Silver Member
    • Total Posts : 68
    • Scores: 0
    • Reward points: 0
    • Joined: 2012/05/24 20:31:44
    • Status: offline
    RE: DHCP not work 2014/10/07 18:54:37 (permalink)
    0
    Hi Aury,
    I' m not expert. But perhaps I can help you.
    - what is your IP segment for that interface?
    - how you determine IP range for DHCP?
    - is the administrative status UP?
    #12
    Fatih
    Bronze Member
    • Total Posts : 21
    • Scores: 0
    • Reward points: 0
    • Joined: 2014/10/08 07:27:11
    • Status: offline
    RE: DHCP not work 2014/10/09 02:28:43 (permalink)
    0
    Hi,

    Can you test as follows.

    config system dhcp server
    edit 0
    set auto-configuration disable
    set default-gateway 192.168.100.1
    set dns-service default
    set interface " INTERFACE NAME"
    config ip-range
    edit 1
    set end-ip 192.168.100.170
    set start-ip 192.168.100.153
    next
    end
    set lease-time 300
    set netmask 255.255.255.0
    next
    end

    #13
    FortiLearner
    New Member
    • Total Posts : 6
    • Scores: 0
    • Reward points: 0
    • Joined: 2017/05/09 04:37:56
    • Status: offline
    Re: RE: DHCP not work 2017/11/14 07:52:47 (permalink)
    0
    Hi Papapuff,
     
    The IP address of the interface is not is the same network as the DHCP provding
    In the image provided the interface is 192.168.1.1 and the DHCP scope is 192.168.100.X
     
    The Firewall is trying to assign the DHCP range to the devices connecting to 192.168.1.1.
     
    In order to correct this you will need to assign a interface/VLAN with the ip address 192.168.100.X if you are making the gateway a router or switch.
    If you making the firewall the gateway then you need to assign 192.168.100.1.
     
    Also if you are upgrading a firewall in the same version but a new patch there should be no need to do changes on the firewall, all should remain the same.
     
    Regards,
    Learner
     
    #14
    rwpatterson
    Expert Member
    • Total Posts : 8040
    • Scores: 157
    • Reward points: 0
    • Joined: 2006/08/08 10:08:18
    • Location: Long Island, New York, USA
    • Status: online
    Re: RE: DHCP not work 2017/11/14 10:05:05 (permalink)
    0
    Have you tried un-checking the box next to the default gateway option in the DHCP server setup? You may then specify the gateway of the secondary IP.
     
    Try that one out.

    -Bob - self proclaimed posting junkie!
    See my Fortigate related scripts at: http://fortigate.camerabob.com

    -4.3.18-b0689
    FGT60B
    FWF60B
    FWF80CM (2)
    FWF81CM
     
    #15
    Jump to:
    © 2017 APG vNext Commercial Version 5.5