Hot!SIP problems after firmware update

Author
soundxplorer
New Member
  • Total Posts : 12
  • Scores: 0
  • Reward points: 0
  • Joined: 2018/12/19 11:55:28
  • Status: offline
2021/09/13 12:13:00 (permalink)
0

SIP problems after firmware update

I have an LAN hardware devices that requires the SIP Helper to be disabled in my Fortigate, and it was working fine for a long time until today. (I disabled SIP Helper properly a long time ago using these instructions: https://kb.fortinet.com/kb/documentLink.do?externalID=FD36405)
 
The only thing that changed recently is I updated my F100E from firmware 6.0.10 to 6.0.12 yesterday.
Now my internal application is not working properly. The firmware update is the only thing that has changed.
 
Has anyone experienced SIP protocol issues after updating your firmware? 
Thanks
#1

2 Replies Related Threads

    lobstercreed
    Expert Member
    • Total Posts : 468
    • Scores: 61
    • Reward points: 0
    • Joined: 2018/11/28 14:57:58
    • Location: Sedalia, MO
    • Status: online
    Re: SIP problems after firmware update 2021/09/13 15:14:44 (permalink)
    0
    Yes, I am not sure when it started exactly but I seem to be having some issues at least since 6.4.6 and continuing with 6.4.7

    However in my case I have always had the SIP ALG enabled and it mostly works right but sometimes the Contact URI Host Part is not translated. The Via portion (Sent-by Address) seems to be correctly translated in all cases, but randomly the Contact URI may or may not be.  This can cause strange issues including one-way audio.
    #2
    soundxplorer
    New Member
    • Total Posts : 12
    • Scores: 0
    • Reward points: 0
    • Joined: 2018/12/19 11:55:28
    • Status: offline
    Re: SIP problems after firmware update 2021/09/14 08:51:18 (permalink)
    0
    Still not working.
    I've deleted the SIP protocol entry #13 from the list.
    I've tried all of these settings in my VoIP profile:
    config sip
    set status disable
    set rtp disable
    set contact-fixup disable
    set strict-register disable
     
    The REALLY strange thing is, last night I updated to 6.0.13 and rebooted. After my F100E came back up, I test my SIP call hardware and it worked. I thought it was fixed. Then this morning, without changing anything, it is NOT working anymore.
     
    I can confirm with packet captures that the ports are being changed, from 5060 to a random number anywhere between 4000 - 50,000.
     
    Can anyone suggest other things to try? 
    #3
    Jump to:
    © 2021 APG vNext Commercial Version 5.5