Forticlient for Linux can only connect to ONE MFA-enabled firewall

Author
caos
New Member
  • Total Posts : 3
  • Scores: 0
  • Reward points: 0
  • Joined: 2020/09/07 01:29:02
  • Status: offline
2021/07/19 23:45:48 (permalink)
0

Forticlient for Linux can only connect to ONE MFA-enabled firewall

I'm running Forticlient 7.0.0.0018 on Ubuntu 20.04. 
 
I've configured it to connect to my company's Fortigate 100F using SAML, and it works well. I was surprised to see that it appeared to cache both username and password as I only needed to enter those first time I connected. It doesn't even prompt me for a one-time SMS code. The Windows version requires me to enter both username and password plus SMS code every time I connect. Not top security but I must confess it's quite convenient when working from home. 
 
Now one of my customers has enabled SAML on their 100F as well. When I try to connect to their firewall, Forticlient still tries to connect using my company credentials, even though I specified what username to use when I configured the new client VPN. 
 
I renamed the ~/.config/FortiClient/Cookies file and that made it possible to enter all credentials and connect to the client's firewall -- but now Forticlient tries to use those credentials for my company's VPN as well!
 
Everything works well in the Windows client, so what can I do to make the Linux client work the same way?
#1

0 Replies Related Threads

    Jump to:
    © 2021 APG vNext Commercial Version 5.5