Helpful ReplyHot!VOIP issues fortiwifi f50e

Author
leo@agent_it
New Member
  • Total Posts : 3
  • Scores: 0
  • Reward points: 0
  • Joined: 2021/04/07 12:21:24
  • Status: offline
2021/04/07 12:24:24 (permalink)
0

VOIP issues fortiwifi f50e

Installed FortiWiFi 50E , firmware 6.2.7 build 1190
 
Issue: VOIP phones are working except for park function. When receptionist parks a call, the next user cannot hear the call if the pick up the parks call. Weird thing is that if the pick up the parked call, place it on hold and then resume the call, the call will then proceed as normal. So: can't pickup parked calls unless you press hold twice.
 
What we've tried:
1. disable sip ALG helpers through CLI
2. Created a few services to allow traffic on ports: 53 UDP 5060-5062 UDP 20000-40000 UDP and allowed these services to talk from LAN to WAN and from WAN to LAN
3. rebooted phones, switches, firewall etc.
4. Created a ticket with Fortinet, currently they are researching the issue...but my client is a Karen and is breathing down my back.
 
Thank you for any help!
#1
emnoc
Expert Member
  • Total Posts : 6055
  • Scores: 404
  • Reward points: 0
  • Joined: 2008/03/20 13:30:33
  • Location: AUSTIN TX AREA
  • Status: offline
Re: VOIP issues fortiwifi f50e 2021/04/08 00:42:54 (permalink) ☄ Helpfulby leo@agent_it 2021/04/08 06:19:34
0
So call park should be part of the SIP:protocol. Do you have , or can take pcap from the phone perspective ? I believe it's encode in SIP call-control via "REFER" messages.
 
So you need a full call-signaling dump to see what's going on within the REFER/INVITE/RE_INVITE/NOTIFY etc.......Also make sure the phones firmware are updated but I would get a pcap started for analysis of the SIP protocol ( udp/tcp-5060/5061 ) 
 
Sorry my SIP t-shooting skills are poor since I haven't decode SIP messages in the last  6 + years ;)
 
Ken Felix
 

PCNSE 
NSE 
StrongSwan  
#2
leo@agent_it
New Member
  • Total Posts : 3
  • Scores: 0
  • Reward points: 0
  • Joined: 2021/04/07 12:21:24
  • Status: offline
Re: VOIP issues fortiwifi f50e 2021/04/08 06:22:45 (permalink)
0
Thanks Felix, 
   I will look and see if I can take a pcap from the phone perspective! Might have to get with the VOIP provider and see if they can help me get that info. 
#3
leo@agent_it
New Member
  • Total Posts : 3
  • Scores: 0
  • Reward points: 0
  • Joined: 2021/04/07 12:21:24
  • Status: offline
Re: VOIP issues fortiwifi f50e 2021/04/08 10:51:24 (permalink)
0
My problem was that there was a session established after I disabled SIP ALG. 
My issue was in "edit 13" so deleting that within the session helper edits cleared out my issue. 

# config system session-helper

      show

Amongst the displayed settings will be one similar to the following example:

 edit 13

       set name sip

       set protocol 17

       set port 5060

next

        

Here entry 13 is the one which points to SIP traffic which uses UDP port 5060 for signaling.



delete 13

end
#4
emnoc
Expert Member
  • Total Posts : 6055
  • Scores: 404
  • Reward points: 0
  • Joined: 2008/03/20 13:30:33
  • Location: AUSTIN TX AREA
  • Status: offline
Re: VOIP issues fortiwifi f50e 2021/04/08 12:14:47 (permalink)
0
Okay good 
 
Ken Felix

PCNSE 
NSE 
StrongSwan  
#5
Jump to:
© 2021 APG vNext Commercial Version 5.5