Hot!Problem implementation FORTILINK

Author
marciohx
New Member
  • Total Posts : 5
  • Scores: 0
  • Reward points: 0
  • Joined: 2018/11/13 12:22:32
  • Status: offline
2021/02/26 05:09:09 (permalink)
0

Problem implementation FORTILINK

My friends, I have two switches 424E and two 148F. The SWs are with version 6.4.6. My Fortigate VM is version 6.4.4. My topology is very simple! The two 424E receive the same fortilink (a STACK) and each with a 148F. But this is not working! I turned off the "split interface" as recommended. Only one side is working( 424E + 148F). Is there a problem or configuration on VMWARE (vswith for example) !? If I use two Fortilinks (two STACKs), I see two working! I need to have all switches on the same STACK.

Thanks in advanced,
Marcio - HXBRASIL
#1

5 Replies Related Threads

    nicerobot_FTNT
    Bronze Member
    • Total Posts : 23
    • Scores: -2
    • Reward points: 0
    • Joined: 2020/12/09 09:02:59
    • Location: USA
    • Status: offline
    Re: Problem implementation FORTILINK 2021/02/26 07:02:54 (permalink)
    0
    Marcio,
     
    You'll have to set up MC-LAG between the 424E's using an ICL (inter-chassis link) then connect the 148Fs via ISL to each 424E. Only after you set up the MC-LAG would you disable split interface on the FortiLink. Have you gone through the multi-chassis LAG setup?
     
    Thanks

    ---
    Opinions expressed are my own and may not represent the official opinion of my employer.
    #2
    marciohx
    New Member
    • Total Posts : 5
    • Scores: 0
    • Reward points: 0
    • Joined: 2018/11/13 12:22:32
    • Status: offline
    Re: Problem implementation FORTILINK 2021/03/01 07:57:23 (permalink)
    0
    Thanks for the answer! But which topology should I use?
    a) Two FORTLINKS interfaces
    or
    b) A FORTILINK interface
     
    Thank you again!
    Marcio
    #3
    nicerobot_FTNT
    Bronze Member
    • Total Posts : 23
    • Scores: -2
    • Reward points: 0
    • Joined: 2020/12/09 09:02:59
    • Location: USA
    • Status: offline
    Re: Problem implementation FORTILINK 2021/03/01 10:02:49 (permalink)
    0
    You're going to have ONE FortiLink interface with two interfaces in it. You will just add multiple interfaces in the FortiLink interface setup:
        edit "FortiLink"
            set vdom "root"
            set fortilink enable
            set ip 192.168.121.1 255.255.255.0
            set allowaccess ping fabric
            set type aggregate
            set member "port23" "port24"
            set description "FortiLink"
            set lldp-reception enable
            set lldp-transmission enable
            set snmp-index 9
            set auto-auth-extension-device enable
            set lacp-mode static
        next
     
    Most of this should be pretty intuitive from the GUI interface.

    ---
    Opinions expressed are my own and may not represent the official opinion of my employer.
    #4
    marciohx
    New Member
    • Total Posts : 5
    • Scores: 0
    • Reward points: 0
    • Joined: 2018/11/13 12:22:32
    • Status: offline
    Re: Problem implementation FORTILINK 2021/03/02 11:15:51 (permalink)
    0
    My fried,
     
    You very nice! Thank you for everything! But it still didn't work! It really should be easy, but I don't know what's going on! See my configuration:
     
    edit "fortilink"
    set vdom "root"
    set fortilink enable
    set ip 169.254.1.1 255.255.255.0
    set allowaccess ping fabric
    set type aggregate
    set member "port9" "port10"
    set lldp-reception enable
    set lldp-transmission enable
    set snmp-index 12
    set auto-auth-extension-device enable
    set fortilink-split-interface disable
    set switch-controller-nac "fortilink"
    set swc-first-create 127
    set lacp-mode static
    next
     
    What do you think about it? is there problem in the VMWARE?  set member "port9" "port10" - only one port working for time.  I have only the half of the topology!  Do you have idea?  
     
    The FORTIGATE VM is implemented in a host ESXi 6.0 STANDALONE.

    Thank you very much!
    Marcio

     


     





     
     

     

     
    #5
    ac
    Bronze Member
    • Total Posts : 36
    • Scores: 4
    • Reward points: 0
    • Status: offline
    Re: Problem implementation FORTILINK 2021/08/02 05:21:21 (permalink)
    0
    You need to create a new fortilink interface that is not of type aggregate.
    You must create a new hardware switch and set it a FortiLink interface with the command:
    set fortilink enable
    #6
    Jump to:
    © 2021 APG vNext Commercial Version 5.5