Hot!PPPoE Settings Failed

Author
FDemir
New Member
  • Total Posts : 2
  • Scores: 0
  • Reward points: 0
  • Joined: 2020/10/05 03:11:36
  • Status: offline
2020/10/05 03:19:35 (permalink)
0

PPPoE Settings Failed

Hi,
 
Device : FG 40F
I try to configure PPPoE settings on WAN port. But it says "failed". I tried with 2 different environment, 5 different modems. I put modems on brigde mode and disabled DHCP. I can't solve the problem.
#1

4 Replies Related Threads

    Andy Bailey
    Silver Member
    • Total Posts : 91
    • Scores: 14
    • Reward points: 0
    • Joined: 2016/06/27 11:21:22
    • Status: offline
    Re: PPPoE Settings Failed 2020/10/05 04:48:58 (permalink)
    0
    Hi FDemir,
     
    It really depends on your ISP and what settings they require- so it's hard to be specfic in response to your question. Your ISP modem should be in bridge mode if you want the Fortigate to control the PPPOE session (which is probably best).
     
    I use PPPOE on two Fortigates (one is 40F) and have no issues at all. But it isn't always easy to align with what the ISP needs.
     
    It also gets more complex if you need IPv6 too- that again adds complexity.
     
    Here is a link to an older post discussing PPPOE and IPv6 specifically:-
     
    https://forum.fortinet.com/FindPost/182048
     
    It may help you- it talks about the PPOE settings generally and provides some config snippets which might help you.
     
    Good luck.
     
    Kind Regards,
     
     
    Andy/
    #2
    FDemir
    New Member
    • Total Posts : 2
    • Scores: 0
    • Reward points: 0
    • Joined: 2020/10/05 03:11:36
    • Status: offline
    Re: PPPoE Settings Failed 2020/10/05 04:58:14 (permalink)
    0
    Hi Andy,
     
    I don't need IPv6. When I write my ISP username and password to WAN interface's PPPoE settings, I should see my public IP here. But it says failed.
    #3
    Yurisk
    Silver Member
    • Total Posts : 110
    • Scores: 22
    • Reward points: 0
    • Joined: 2011/12/04 03:30:01
    • Status: offline
    Re: PPPoE Settings Failed 2020/10/05 06:02:47 (permalink)
    0
    By "failed" do you mean in logs, or you can't put PPPoE configuration under the interface? 
    Try to run debug on the SSH/Console to see what is going on when it tries to connect:
     
    diag debug application pppoed -1
    dia debug application pppoe -1
    dia debug applicaiton ppp -1
    diag deb enable

     
    Also make sure your PPPoE modem is synchronized and has working signal/noise ratio (ISP can see it remotely).
    #4
    sw2090
    Expert Member
    • Total Posts : 783
    • Scores: 58
    • Reward points: 0
    • Joined: 2017/06/14 01:27:25
    • Location: Regensburg
    • Status: offline
    Re: PPPoE Settings Failed 2020/10/05 07:09:48 (permalink)
    0
    basically:
     
    if modem is in bridge mode the FGT does the PPPOE session. If it sucessfully dialled in in bridge mode you will see the external ip on the FGT If modem is not in bridge mode you have to set the FGT to do dhcp or have static ip on the iterface connected to modem. In this case you will not see the external ip on the FGT.
     
    If you are in bridge mode you can use the cli debug commands that were posted here by someone else already to get some more info.
     
    #5
    Jump to:
    © 2020 APG vNext Commercial Version 5.5