Helpful ReplyHot!Fortigate VM Evaluation License not working since FortiOS 6.0.1

Author
Marcel Sueess
New Member
  • Total Posts : 13
  • Scores: 4
  • Reward points: 0
  • Joined: 2014/07/29 11:30:01
  • Status: offline
2018/10/21 05:24:39 (permalink) 6.0
0

Fortigate VM Evaluation License not working since FortiOS 6.0.1

Hi all
 
for testing, there was an integrated evaluation license for 15 days in each Fortigate VM. Since FortiOS 6.0.1 the evaluation license expires right from the first start of the virtual machine. In the GUI, there is the message "Expired on 1970/01/01" with the possibility to upload a license file. Until FortiOS 6.0.0 it works as before.
 
Was the feature for evaluation license removed or is this a bug?
 
I tested with FortiOS 6.0.1, 6.0.2 and 6.0.3 with VMware Workstation 12.5.
 
Thanks for your help.
 
Best regards
Marcel
#1
Penultimatum
New Member
  • Total Posts : 1
  • Scores: 0
  • Reward points: 0
  • Joined: 2018/11/09 08:01:01
  • Status: offline
Re: Fortigate VM Evaluation License not working since FortiOS 6.0.1 2018/11/09 08:02:57 (permalink)
0
No answer to this?  I have just found the same problem.
 
I have downloaded the VM hoping to use the evaluation period to help with NSE4 study, but it appears its no longer possible?
#2
neonbit
Expert Member
  • Total Posts : 531
  • Scores: 69
  • Reward points: 0
  • Joined: 2013/07/02 21:39:52
  • Location: Dark side of the moon
  • Status: offline
Re: Fortigate VM Evaluation License not working since FortiOS 6.0.1 2018/11/11 03:24:36 (permalink)
0
I've installed a FGT VM on 6.0.1 and 6.0.3 and they both work fine in eval mode.
 
One thing to note is that you have to give it only 1GB and 1CPU for it to work properly. Also it's very restriced (I think only 5 policies and no VPN/encryption).
#3
Marcel Sueess
New Member
  • Total Posts : 13
  • Scores: 4
  • Reward points: 0
  • Joined: 2014/07/29 11:30:01
  • Status: offline
Re: Fortigate VM Evaluation License not working since FortiOS 6.0.1 2018/11/11 04:44:57 (permalink)
0
Hi neonbit
 
thank you very much for your reply and the test. I knew the limitation for RAM and CPU and also the restrictions for the number of policies.
 
I tried it again and I think, I found the problem. After importing the image into VMware Workstation, I have to check a box on time settings under the options of the VM. Seems, that it was checked by default on the 6.0.0 releases and before. (See attachment)
 
Best regards
Marcel
post edited by Marcel Sueess - 2018/11/11 04:46:33

Attached Image(s)

#4
chirag.rao
New Member
  • Total Posts : 6
  • Scores: 0
  • Reward points: 0
  • Joined: 2018/10/17 07:24:54
  • Status: offline
Re: Fortigate VM Evaluation License not working since FortiOS 6.0.1 2019/06/17 05:19:15 (permalink)
0
Hi Marcel,
 
I tried it, but still the same problem. I am trying the latest image 6.2.0 on VMware Workstation 12.5.5.
 
Error: *ATTENTION*: Admin sessions removed because license registration status changed to 'INVALID'
 
I tried downloading a fresh image a couple of times, but that did not help either. With earlier images, it used to work seamless.
 
Any help from anyone?
 
Regards,
Chirag Rao
#5
dennisv
New Member
  • Total Posts : 11
  • Scores: -1
  • Reward points: 0
  • Joined: 2017/03/14 08:31:55
  • Status: offline
Re: Fortigate VM Evaluation License not working since FortiOS 6.0.1 2019/07/26 03:34:24 (permalink)
0
I noticed this one on reddit aswell and here is a copy-paste of what I posted there.
 
Here is what I did to get it working in VMware Player, but workstation should be the same.
Default VM ovf (no hw04/vmxnet) , network in bridged mode.
import vm
edit vm settings
tab1, all interfaces disable connect at power on
tab2, time sync with host enabled
start vm
-wait for prompt-
admin / <enter>
# get system status
-check for evaluation time expires and correct system time at bottom-
# config system ntp
# set ntpsync disable
# set type custom
# end
edit vm settings
tab1
set all interfaces to connected and connect at power on
# get system interface
-look for the ip on port1 and connect to webgui via https

Consultant @ Exclusive Networks BV
Datacenter Networking and Security
NSE4 6.0
Fortinet, HPe/Aruba, Arista, Juniper and many more
#6
Marcel Sueess
New Member
  • Total Posts : 13
  • Scores: 4
  • Reward points: 0
  • Joined: 2014/07/29 11:30:01
  • Status: offline
Re: Fortigate VM Evaluation License not working since FortiOS 6.0.1 2019/07/27 06:00:27 (permalink)
0
Hi Dennis
 
thank you very much for your information. I tried your steps exactly as described even with version 6.2.1 and it worked for me. Thanks.
 
Greets
Marcel
#7
vmwaredinesh@gmail.com
New Member
  • Total Posts : 1
  • Scores: 0
  • Reward points: 0
  • Joined: 2019/08/18 00:43:28
  • Status: offline
Re: Fortigate VM Evaluation License not working since FortiOS 6.0.1 2019/08/18 00:47:48 (permalink)
0
dennisv
I noticed this one on reddit aswell and here is a copy-paste of what I posted there. Here is what I did to get it working in VMware Player, but workstation should be the same.
Default VM ovf (no hw04/vmxnet) , network in bridged mode.import vm
edit vm settings
tab1, all interfaces disable connect at power on
tab2, time sync with host enabled
start vm-wait for prompt-
admin / <enter>
# get system status
-check for evaluation time expires and correct system time at bottom-
# config system ntp
# set ntpsync disable
# set type custom
# endedit vm settings
tab1
set all interfaces to connected and connect at power on# get system interface
-look for the ip on port1 and connect to webgui via https



i tried these steps. After enabling the adapters the NTP settings revert back to Fortigaurd. Am i doing anything wrong ? do i need to do anything to save the config ?
#8
Marcel Sueess
New Member
  • Total Posts : 13
  • Scores: 4
  • Reward points: 0
  • Joined: 2014/07/29 11:30:01
  • Status: offline
Re: Fortigate VM Evaluation License not working since FortiOS 6.0.1 2019/08/20 10:46:39 (permalink)
0
Hi,
 
did you really execute the following commands (incl. the "end" to save) in the cli?
config system ntp
set ntpsync disable
set type custom
end

For me it worked as expected with the FortiOS 6.2.1.
 
Greets
Marcel
#9
femi
New Member
  • Total Posts : 1
  • Scores: 2
  • Reward points: 0
  • Joined: 2019/09/10 08:39:29
  • Status: offline
Re: Fortigate VM Evaluation License not working since FortiOS 6.0.1 2019/09/10 08:43:12 (permalink) ☄ Helpfulby cijfferr 2019/09/13 07:20:42
5 (1)
exec factoryreset resolved the eva license issue. I'm running it on Hyper-V.
#10
cijfferr
New Member
  • Total Posts : 1
  • Scores: 0
  • Reward points: 0
  • Joined: 2015/09/15 09:52:52
  • Status: offline
Re: Fortigate VM Evaluation License not working since FortiOS 6.0.1 2019/09/13 07:21:49 (permalink)
3 (1)
femi
exec factoryreset resolved the eva license issue. I'm running it on Hyper-V.


Strange to factory reset a brand new VM, but it works! tx
#11
Xpr3ssioN
New Member
  • Total Posts : 1
  • Scores: 0
  • Reward points: 0
  • Joined: 2019/10/12 03:27:53
  • Status: offline
Re: Fortigate VM Evaluation License not working since FortiOS 6.0.1 2019/10/12 03:31:30 (permalink)
0
femi
exec factoryreset resolved the eva license issue. I'm running it on Hyper-V.


This worked for me also in VMWare Workstation Pro and running 6.0.6 image
Changing time settings and such did not work for me.
#12
Jump to:
© 2019 APG vNext Commercial Version 5.5