Hot!Timeout on snmpwalk

Author
Muahammed
New Member
  • Total Posts : 5
  • Scores: 0
  • Reward points: 0
  • Joined: 2015/11/30 19:57:48
  • Status: offline
2018/10/05 22:04:32 (permalink)
0

Timeout on snmpwalk

Hello,
 
I've noticed a strange problem on  FortiOS 5.4.8, FortiGate 80D.
The SNMP is enabled and correctly configured. On my LAN interface, the SNMP is enabled, but I can't run a snmpwalk at all(timeout)
 
FW01 # diagnose snmpd: updating cache: idx_cache
snmpd: trap request mem_low(0000000000000066) -> queue 1 in 0, 0 interval
snmpd: queue is 0 entries long.
snmpd: queueing trap 8000000000000002@1035799 (1035799)
snmpd: queue is 1 entries long.
snmpd: dequeueing trap 8000000000000002@1035799 (1035799)
snmpd: sending to hosts: mem_low(102)
snmpd: _trap4_prep:538 connect 169.254.0.1:162 vd=2 (type 3) errno=101 (Network is unreachable)
snmpd: trap request mem_low(0000000000000066) -> queue 1 in 0, 0 interval
snmpd: queue is 0 entries long.
snmpd: queueing trap 8000000000000002@1037399 (1037399)
snmpd: queue is 1 entries long.
snmpd: dequeueing trap 8000000000000002@1037399 (1037399)
snmpd: sending to hosts: mem_low(102)
snmpd: _trap4_prep:538 connect 169.254.0.1:162 vd=2 (type 3) errno=101 (Network is unreachable)
 
if somebody know how to solve this issue or have an idea? pls advice me
 
Thanks.
 
#1

2 Replies Related Threads

    HaTiMuX
    New Member
    • Total Posts : 20
    • Scores: 4
    • Reward points: 0
    • Joined: 2017/04/26 07:57:16
    • Status: offline
    Re: Timeout on snmpwalk 2020/06/17 09:18:47 (permalink)
    0
    Hi,
     
    Make sure the SNMP Agent is enabled:
    config system snmp sysinfo
    set status enable
    end
     
    Also verify your trusted hosts and the configuration of your community:
    https://kb.fortinet.com/kb/documentLink.do?externalID=FD45755
     
    #2
    emnoc
    Expert Member
    • Total Posts : 5748
    • Scores: 373
    • Reward points: 0
    • Joined: 2008/03/20 13:30:33
    • Location: AUSTIN TX AREA
    • Status: offline
    Re: Timeout on snmpwalk 2020/06/17 10:32:10 (permalink)
    0
    To add ensure allowaccess from cli or webUI has snmp allowed, if this is not added your snmp will fail and timeout.
     
     
    e.g
     
      config sys interface 
         edit wan1
               set allowaccess ssh https snmp
         end
     
    Ken Felix
     

    PCNSE 
    NSE 
    StrongSwan  
    #3
    Jump to:
    © 2020 APG vNext Commercial Version 5.5