Hot!Issue with FTP

Author
scottwheldon
New Member
  • Total Posts : 3
  • Scores: 0
  • Reward points: 0
  • Joined: 2018/08/12 23:05:32
  • Status: offline
2018/08/13 00:03:03 (permalink)
0

Issue with FTP

Hi,
I need some help with getting FTP access going please.
I have a FG60 series and a QNAP on the LAN that I want to have access going for FTP access.
I have a standard VIP setup and a Policy in place
FTP service inside the LAN works totally fine.
I have other port forwards setup fine as well, such as RDP, PPTP etc...
 
I am getting the following error message from FileZilla: Server sent passive reply with unroutable address. Using server address instead.
 
I just can;t see where/how/why its not working, going crazy.
 
EDIT on this - I am trying to do FTP over TLS, not pure unencrypted  FTP - sorry for any confusion.
 
Thankyou so much, Scott
 
post edited by scottwheldon - 2018/08/13 04:32:52
#1

3 Replies Related Threads

    emnoc
    Expert Member
    • Total Posts : 4988
    • Scores: 306
    • Reward points: 0
    • Joined: 2008/03/20 13:30:33
    • Location: AUSTIN TX AREA
    • Status: offline
    Re: Issue with FTP 2018/08/13 01:31:46 (permalink)
    0
    Is it a one-4-one NAT? What happening if you run pasv in debug, the server is giving an address that's not  recognizable by the  ftp-client  and probably is the internal address.
     
    Do a debug  on the client compute the given address.? Fix up  the    ftp session between server and client
     
     
    http://help.fortinet.com/...n%20helper%20(ftp).htm

    PCNSE,  NSE , Forcepoint ,  StrongSwan Specialist
    #2
    ede_pfau
    Expert Member
    • Total Posts : 5680
    • Scores: 385
    • Reward points: 0
    • Joined: 2004/03/09 01:20:18
    • Location: Heidelberg, Germany
    • Status: offline
    Re: Issue with FTP 2018/08/13 01:52:24 (permalink)
    0
    One published 'solution' is to disable the FTP session helper.

    Ede

    " Kernel panic: Aiee, killing interrupt handler!"
    #3
    scottwheldon
    New Member
    • Total Posts : 3
    • Scores: 0
    • Reward points: 0
    • Joined: 2018/08/12 23:05:32
    • Status: offline
    Re: Issue with FTP 2018/08/19 17:00:25 (permalink)
    0
    Hi,
     
    update on this, I have fixed it.
     
    I had to change the settings in Security Profiles -> SSl Inspection to FULL SSL Inspection and then select FTPS as per the attached image.
     
    Scott

    Attached Image(s)

    #4
    Jump to:
    © 2018 APG vNext Commercial Version 5.5