Hot!PIM-SM routing

Author
chrismes
New Member
  • Total Posts : 6
  • Scores: 0
  • Reward points: 0
  • Joined: 2015/08/26 10:43:17
  • Status: offline
2018/05/28 21:49:45 (permalink)
0

PIM-SM routing

The PIM-SM routing examples in the "Networking handbook" are not very clear. Why is there added an access-list, which is never used int the config?
Has anyone a really working PIM-routing example from practice?
Thanks.
#1

2 Replies Related Threads

    ericli_FTNT
    Gold Member
    • Total Posts : 127
    • Scores: 4
    • Reward points: 0
    • Joined: 2018/02/08 11:12:27
    • Status: offline
    Re: PIM-SM routing 2018/05/30 09:50:36 (permalink)
    0
    On Fortigate, to enable multicast routing, you will need to:
    1.
    config system settings
    set multicast-forward enable
    end

     
    2.
    config router multicast
    set multicast-routing enable
    end

     
    3.
    config router multicast
    config pim-sm-global
    config rp-address
    ...
    set ip-address x.x.x.x

     
    4.
    config router multicast
    config interface
    edit xx
    set pim-mode sparse-mode
    end

     
    5.
    config firewall multicast-policy

     
    Here are some trouble shooting commands:
     
    get router info multicast pim sparse-mode table x.x.x.x
    get router info multicast pim sparse-mode neighbour
    diagnose ip multicast mroute
    get router info multicast igmp groups
    get router info multicast pim sparse-mode interface
    get router info multicast pim sparse-mode rp-mapping
    get router info multicast pim sparse-mode bsr-info
    diagnose sys mcast-session list

     
    Follow up with this thread with any question please. Thanks!
    post edited by ericli_FTNT - 2018/05/30 09:53:22
    #2
    topcu@ipsystems
    New Member
    • Total Posts : 7
    • Scores: 0
    • Reward points: 0
    • Joined: 2018/09/18 06:48:15
    • Status: offline
    Re: PIM-SM routing 2019/01/15 03:04:26 (permalink)
    0
    chrismes
    Why is there added an access-list, which is never used int the config?


    Hi, chrismes asked for the purpose of the access-list in the fortinet configuraion guide. Honestly, this was also not absolutely clear for me, because the ACL ist not referenced somewhere else in one documentation.
     
    http://help.fortinet.com/...%20a%20static%20RP.htm
     
    But I know, that an RP can be restricted to specific Multicastgroups via an ACL. I found another configuration Guide with the following configuration example:
     
    https://pub.kb.fortinet.com/ksmcontent/Fortinet-Public/current/Fortigate_v4.0/From_TD/FortiGate_Multicast_Tech_Note_01-400-96951-20090521.pdf
     
    The ACL defines a filter to the multicastgroup 233.254.200.0
    config router access-list
     edit "Source-RP"
      config rule
       edit 1
        set prefix 233.254.200.0 255.255.255.0
        set exact-match disable
    next
     
    In another step, the ACL is bound to teh RP:
    config router multicast
     config interface
      edit "internal"
       set pim-mode sparse-mode
        config igmp
         set version 2
     end
    next
     edit "external"
      set pim-mode sparse-mode
       config igmp
       set version 2
     end
    next
    end
     set multicast-routing enable
      config pim-sm-global
       config rp-address
        edit 1
         set ip-address 169.254.100.1
         set group "Source-RP"
    next
    #3
    Jump to:
    © 2019 APG vNext Commercial Version 5.5