Memory Usage goes high

Author
Aaron Abrincia Meimban
Bronze Member
  • Total Posts : 22
  • Scores: 0
  • Reward points: 0
  • Joined: 2014/09/08 14:25:33
  • Status: offline
2014/09/09 04:55:23 (permalink)
0

Memory Usage goes high

HI Engineers,

Would you able to explain to me why we are reaching 73% of memory and could it possible to decrease the consumption of the memory?




Regards
Aaron
#1

17 Replies Related Threads

    jorge9090
    Bronze Member
    • Total Posts : 43
    • Scores: 2
    • Reward points: 0
    • Joined: 2014/09/01 07:03:53
    • Location: Mexico
    • Status: offline
    RE: Memory Usage goes high 2014/09/09 07:27:39 (permalink)
    0
    Hello Aaron, can you tell us the Model and FortiOS you are working with? Do you have features like Web filtering or app control enabled? vdoms?

    You can check the performance of the FGT with

    FGT# get system performance status

    #2
    ede_pfau
    Expert Member
    • Total Posts : 6354
    • Scores: 537
    • Reward points: 0
    • Joined: 2004/03/09 01:20:18
    • Location: Heidelberg, Germany
    • Status: offline
    RE: Memory Usage goes high 2014/09/09 09:27:20 (permalink)
    0
    So you are running FOS 5.0.9 on an active-passive cluster. Your FGT has a 4-core CPU.

    73% memory looks like a bit high after only 16 days of uptime. After a reboot, how long does it take to reach 70% again? With which consumptions does it start?

    Please research the Knowledgebase and the forums for " high memory" . Especially in the KB you will find articles outlining steps which can help reduce memory footprint.

    Ede

    " Kernel panic: Aiee, killing interrupt handler!"
    #3
    hklb
    Gold Member
    • Total Posts : 233
    • Scores: 31
    • Reward points: 0
    • Joined: 2014/06/10 15:00:59
    • Status: offline
    RE: Memory Usage goes high 2014/09/09 09:38:48 (permalink)
    0
    You can check the top process :
    diagnose sys top-summary
    #4
    Aaron Abrincia Meimban
    Bronze Member
    • Total Posts : 22
    • Scores: 0
    • Reward points: 0
    • Joined: 2014/09/08 14:25:33
    • Status: offline
    RE: Memory Usage goes high 2014/09/09 11:57:18 (permalink)
    0
    Hi jorge9090,

    Model: 1000C
    FortiOS: v5.0,build0292 (GA Patch 9)

    Web Filtering = Yes
    Application Control = Yes
    VDOM = N/A
    #5
    Aaron Abrincia Meimban
    Bronze Member
    • Total Posts : 22
    • Scores: 0
    • Reward points: 0
    • Joined: 2014/09/08 14:25:33
    • Status: offline
    RE: Memory Usage goes high 2014/09/09 11:57:58 (permalink)
    0
    Hi ede_pfau,

    It takes 2 weeks to reach 70% again. 20% upon restart the device.
    Thank you very much.
    #6
    Aaron Abrincia Meimban
    Bronze Member
    • Total Posts : 22
    • Scores: 0
    • Reward points: 0
    • Joined: 2014/09/08 14:25:33
    • Status: offline
    RE: Memory Usage goes high 2014/09/09 12:05:03 (permalink)
    0
    Hi hklb,

    Upon typing the command this give me an output.



    Regards
    Aaron
    #7
    ede_pfau
    Expert Member
    • Total Posts : 6354
    • Scores: 537
    • Reward points: 0
    • Joined: 2004/03/09 01:20:18
    • Location: Heidelberg, Germany
    • Status: offline
    RE: Memory Usage goes high 2014/09/09 14:42:17 (permalink)
    0
    Looks like the ' proxyd' process is started 8 times and eating up 3 of 8 GB RAM. Do you have UTM features active on a lot of interfaces?

    As nearly every UTM feature is or can be based on a proxy it' s hard to tell which single feature is causing this. I would definitely open a ticket with Customer Support to have this reviewed. This is not a regular usage pattern. Maybe the support person can scan your config for constructs that are unfavorable in terms of memory consumption.

    We could do this as well on the forum but with much less efficiency. I have good experience with CS, very high level of skill and devotion. You should give it a try.

    Ede

    " Kernel panic: Aiee, killing interrupt handler!"
    #8
    Aaron Abrincia Meimban
    Bronze Member
    • Total Posts : 22
    • Scores: 0
    • Reward points: 0
    • Joined: 2014/09/08 14:25:33
    • Status: offline
    RE: Memory Usage goes high 2014/09/10 16:28:42 (permalink)
    0

    Not an interface but every policy has an UTM policy on it such as web filter and application control.

    Yes can you help to do it via remotely?


    Regards
    Aaron
    #9
    ede_pfau
    Expert Member
    • Total Posts : 6354
    • Scores: 537
    • Reward points: 0
    • Joined: 2004/03/09 01:20:18
    • Location: Heidelberg, Germany
    • Status: offline
    RE: Memory Usage goes high 2014/09/11 02:06:37 (permalink)
    0
    Sorry for the misunderstanding. I did not mean " I have a very high level of skill and devotion" but I meant Fortinet Customer Service has. I would go for opening a ticket.

    The forum is not meant to replace Customer Service. Members are 99% users or admins but not Fortinet employees. Your Fortinet partner at your site who sold the FGT should be able to help you - ?

    Ede

    " Kernel panic: Aiee, killing interrupt handler!"
    #10
    MikePruett
    Platinum Member
    • Total Posts : 702
    • Scores: 17
    • Reward points: 0
    • Joined: 2014/01/08 19:39:40
    • Location: Montgomery, Al
    • Status: offline
    RE: Memory Usage goes high 2014/09/11 09:21:57 (permalink)
    0
    Do you have a policy near the top of your rule set that has IPS on it in which most traffic hits?

    It looks like your IPS sensors are eating it alive because of traffic levels and work load.

    #11
    ramakien89
    New Member
    • Total Posts : 1
    • Scores: 0
    • Reward points: 0
    • Joined: 2017/05/04 00:51:21
    • Status: offline
    Re: Memory Usage goes high 2017/05/08 05:02:18 (permalink)
    0
    Hi!
    I am using Fortigate 100D with spec:
    HA StatusStandalone [Configure]Host NameFG100D3G16829885 [Change]Serial NumberFG100D3G16829885Operation ModeNATInspection ModeProxy-based [Change]System TimeMon May 8 18:50:57 2017 (FortiGuard) [Change]Firmware Versionv5.4.3,build1111 (GA) [Update]System Configuration[Backup]  [Restore]  [Revisions]Current Administratoradmin [Change Password] /2 in Total [Details]Uptime2 day(s) 1 hour(s) 42 min(s)Virtual DomainDisabled [Enable]In 2 day work, device will upto 80% memory usage, need reboot, if not reboot, memory will upto 85% then device will can not work, internet wrong, I did turn off and turn on device by button on device. 
     
    #12
    terry.vos
    New Member
    • Total Posts : 5
    • Scores: 0
    • Reward points: 0
    • Joined: 2017/04/06 09:51:06
    • Status: offline
    Re: Memory Usage goes high 2017/05/31 14:35:18 (permalink)
    0
    Watching for resolution. I have a similar issue with High Memory and/or CPU causing Conserve Mode events. I do have  a ticket open with CS, but extra eyes on something never hurts.
    Running an HA pair of 240D, firmware 5.4.4, build 1117.
    #13
    terry.vos
    New Member
    • Total Posts : 5
    • Scores: 0
    • Reward points: 0
    • Joined: 2017/04/06 09:51:06
    • Status: offline
    Re: Memory Usage goes high 2017/05/31 14:36:22 (permalink)
    0
    Sorry - just realized that the original post is from 2014. Doubt that I will see resolution here.
     
    Moderator - please feel free to REMOVE both of my posts on this thread.
    #14
    mike_dp
    Bronze Member
    • Total Posts : 34
    • Scores: 0
    • Reward points: 0
    • Joined: 2016/02/22 12:26:22
    • Status: offline
    Re: Memory Usage goes high 2017/07/28 06:15:50 (permalink)
    0
    240D only has 2gb I believe of RAM so that's not much. Make sure to have UTM policies on the bottom you may also consider upgrading to a bigger box.
     
    #15
    ede_pfau
    Expert Member
    • Total Posts : 6354
    • Scores: 537
    • Reward points: 0
    • Joined: 2004/03/09 01:20:18
    • Location: Heidelberg, Germany
    • Status: offline
    Re: Memory Usage goes high 2017/07/28 06:23:19 (permalink)
    0
    FG-240D has 4 GB of RAM. I'd say that is ample.
    Something else is causing the high consumption - maybe an update process running wild after a signature update, or an engine update.
    Reboot doesn't help?

    Ede

    " Kernel panic: Aiee, killing interrupt handler!"
    #16
    mynghecaocap
    New Member
    • Total Posts : 2
    • Scores: 0
    • Reward points: 0
    • Joined: 2017/08/01 09:42:28
    • Location: Hai Duong
    • Status: offline
    Re: Memory Usage goes high 2017/08/02 05:35:35 (permalink)
    0
    Oh no, I'm getting same issue with Memory Usage , anybody can please explain this problem?
    post edited by mynghecaocap - 2017/09/07 21:33:31
    #17
    MikePruett
    Platinum Member
    • Total Posts : 702
    • Scores: 17
    • Reward points: 0
    • Joined: 2014/01/08 19:39:40
    • Location: Montgomery, Al
    • Status: offline
    Re: Memory Usage goes high 2017/08/02 07:12:08 (permalink)
    0
    the older FortiOS had some memory leak issues. Every device I have had that has experienced this has been resolved as we progressed through FortiOS versions
    #18
    Jump to:
    © 2020 APG vNext Commercial Version 5.5