Helpful ReplyHot!VPN stuck at status 98%

Page: < 12345 > Showing page 4 of 5
Author
ilucas
New Member
  • Total Posts : 11
  • Scores: 0
  • Reward points: 0
  • Joined: 2014/07/04 16:05:09
  • Location: Memphis, TN
  • Status: offline
Re: VPN stuck at status 98% 2016/01/19 05:52:12 (permalink)
0
Has there been any other progress on this?
I have seen some resolutions here and we have been able to perform some of the WAN Miniport fixes, but when it happened to us it was a combination of that and then memory usage.
 
Holy have you managed any progress on this? We saw very similar debug results with ours.

----
FG 200B/30D/60D/80D/100D/200D/300D
FE 200D
#61
Holy
Gold Member
  • Total Posts : 175
  • Scores: 6
  • Reward points: 0
  • Joined: 2014/08/07 03:56:56
  • Status: offline
Re: VPN stuck at status 98% 2016/01/19 06:03:29 (permalink)
0
Hello, no progress at the Moment. much troubleshooting and Ticket escalation by fortinet. But no final result yet. 
 
The Customer is very upset at the moment and dissapointed
#62
jtfinley
Gold Member
  • Total Posts : 189
  • Scores: 0
  • Reward points: 0
  • Joined: 2008/08/11 13:07:10
  • Status: offline
Re: VPN stuck at status 98% 2016/01/19 14:34:00 (permalink)
0
Holy
Hello, no progress at the Moment. much troubleshooting and Ticket escalation by fortinet. But no final result yet. 
 
The Customer is very upset at the moment and dissapointed




What I've done was uncheck IPV6, reboot and it fixed the issue on Windows 7/8 workstations.
#63
Krish
New Member
  • Total Posts : 1
  • Scores: 0
  • Reward points: 0
  • Joined: 2016/01/22 01:33:46
  • Status: offline
Re: VPN stuck at status 98% 2016/01/22 01:43:12 (permalink)
0
I am facing the same issue, VPN not able to connect through FortiClient. I am using latest version 5.4.0.0780, windows 10 64bit. Any suggestions to resolve this would be highly appreciated. Please see the below log file
 
Thanks
 
1/22/2016 9:38:31 AM Debug VPN FortiSslvpn: 8244: fortissl_getstatus(1361) called
1/22/2016 9:38:31 AM Debug ESNAC dwSilentReg false
1/22/2016 9:38:31 AM Debug ESNAC bFirstKA true
1/22/2016 9:38:31 AM Debug ESNAC Start searching for FGT
1/22/2016 9:38:31 AM Debug AntiVirus Cannot send message to the driver(5476:1880). ErrorCode=0x0000001F
1/22/2016 9:38:31 AM Debug ESNAC Searching Default GW
1/22/2016 9:38:33 AM Debug ESNAC Timeout in select in SocketConnect
1/22/2016 9:38:33 AM Debug ESNAC Socket connect failed
1/22/2016 9:38:33 AM Debug ESNAC 172.30.202.1:8013, Secondary - 0
1/22/2016 9:38:33 AM Debug ESNAC Searching Default GW
1/22/2016 9:38:33 AM Debug AntiVirus Cannot send message to the driver(5476:1880). ErrorCode=0x0000001F
1/22/2016 9:38:33 AM Debug AntiVirus (repeated 1 times in last 0 sec) Cannot send message to the driver(5476:1880). ErrorCode=0x0000001F
1/22/2016 9:38:34 AM Debug ESNAC Timeout in select in SocketConnect
1/22/2016 9:38:34 AM Debug ESNAC Socket connect failed
1/22/2016 9:38:34 AM Debug ESNAC 192.168.8.1:8013, Secondary - 0
1/22/2016 9:38:34 AM Debug ESNAC End searching for FGT
1/22/2016 9:38:34 AM Debug VPN FortiSslvpn: CSslvpnBase::RefreshConnection() Called.
1/22/2016 9:38:34 AM Debug AntiVirus Cannot send message to the driver(5476:1880). ErrorCode=0x0000001F
1/22/2016 9:38:49 AM Debug AntiVirus (repeated 12 times in last 15 sec) Cannot send message to the driver(5476:1880). ErrorCode=0x0000001F
1/22/2016 9:38:52 AM Debug ESNAC dwSilentReg false
1/22/2016 9:38:52 AM Debug ESNAC bFirstKA true
1/22/2016 9:38:52 AM Debug ESNAC Start searching for FGT
1/22/2016 9:38:52 AM Debug ESNAC Searching Default GW
1/22/2016 9:38:52 AM Debug AntiVirus Cannot send message to the driver(5476:1880). ErrorCode=0x0000001F
1/22/2016 9:38:52 AM Debug AntiVirus (repeated 17 times in last 1 sec) Cannot send message to the driver(5476:1880). ErrorCode=0x0000001F
1/22/2016 9:38:53 AM Debug ESNAC Timeout in select in SocketConnect
1/22/2016 9:38:53 AM Debug ESNAC Socket connect failed
1/22/2016 9:38:53 AM Debug ESNAC 172.30.202.1:8013, Secondary - 0
1/22/2016 9:38:53 AM Debug ESNAC Searching Default GW
1/22/2016 9:38:53 AM Debug AntiVirus Cannot send message to the driver(5476:1880). ErrorCode=0x0000001F
1/22/2016 9:38:53 AM Debug AntiVirus (repeated 2 times in last 1 sec) Cannot send message to the driver(5476:1880). ErrorCode=0x0000001F
1/22/2016 9:38:53 AM Debug ESNAC Timeout in select in SocketConnect
1/22/2016 9:38:53 AM Debug ESNAC Socket connect failed
1/22/2016 9:38:53 AM Debug ESNAC 192.168.8.1:8013, Secondary - 0
1/22/2016 9:38:53 AM Debug ESNAC End searching for FGT
1/22/2016 9:38:55 AM Debug AntiVirus Cannot send message to the driver(5476:1880). ErrorCode=0x0000001F
#64
JordanAtParkRoadSolutions
New Member
  • Total Posts : 1
  • Scores: 0
  • Reward points: 0
  • Joined: 2016/01/22 12:27:40
  • Status: offline
Re: VPN stuck at status 98% 2016/01/22 12:39:50 (permalink)
0
Hello Everyone,
 
I'm migrating over to Fortinet and ran accross this problem.
I've listed a few possible solutions, the first of which worked for me (Windows 8.1 Pro).
 
Notes:
All solutions below came from the following reddit thread.
Fortinet now has a KB article that re-iterates my "option 3" below.
 
 
 
Option 1 (Worked For Me):
 
1) Open Network Connections 
2) Note the “fortissl” connection will have the device message “Unavailable - device missing” 
3) Open the properties for this connection 
4) On the “General” tab: 
a. Uncheck the “Modem Removed – Unavailable device ()” device 
b. Check the “ISDN channel - PPPoP WAN Adapter” device 
c. Click the up arrow on the right to move the “ISDN channel - PPPoP WAN Adapter” to the top of the list 
d. Set the phone number for the “ISDN channel - PPPoP WAN Adapter” to “1” (without the quotes) 
5) Click “OK” to close the “fortissl” properties 
6) The “fortissl” connection should now appear gray with the device message “PPPoP WAN Adapter” and a status of “Disconnected” 
7) You should now be able to successfully establish an SSL VPN connection

 
Option 2:

 
1) remove all fortigate instalations
2) run CCleaner to remove any remaining files and registry garbage.
3) Reboot
4) Reinstall the latest version of the forticlient. (latest not strictly needed for this)
5) it will still be broken.
6) Go to device manager
7) under network adapters, if you are having the same issue we are, you will see several miniports in a degraded state, with yellow error flags.
8) this is the important part for each one, you need to deliberately misconfigure it before removing it.
  • Do this by selecting update driver software>browse locally>pick from my computer.
  • Uncheck the box that says "show compatible hardware" Point it at any of the microsoft generic network drivers. Literally any driver will do as long as it is wrong.
  • Once this applies (it will yell at you about not working) it will rename the miniport to whatever driver you selected.
  • At this point you can uninstall the device. Do this for every damaged miniport, and then reboot one more time.
"This did it for us in a recent occurrence of this situation." 

 
 
Option 3: Repair Tool
 
For this particular issue, "version 1" and "version 2" of the tool is purported to work under different (undefined) circumstances.
UpdateFortinet has written a KB article recommended procedures for the tool below.[font="arial, helvetica, sans-serif; line-height: 1.8"] 
 
https://www.vpnhosting.cz/index.php/clanky/wan-miniport-repair-tool-solve-vpn-and-dial-up-error-code-720-and-similar-ppperrors.html

 
post edited by JordanAtParkRoadSolutions - 2016/01/22 12:41:21
#65
greylander
New Member
  • Total Posts : 1
  • Scores: 1
  • Reward points: 0
  • Joined: 2016/01/27 06:00:24
  • Status: offline
Re: VPN stuck at status 98% 2016/01/27 06:05:52 (permalink) ☄ Helpfulby pimu 2016/08/09 09:36:49
4 (1)
Hi,
I seem to be experiencing this problem, or very similar problem. 
 
Forticlient hangs at 98% while connecting.  But this only happen occasionally -- especially if the connect dropped for some reason and I try to connect again (possibly every time this happens).
 
I am able to get Forticlient to connect if I reboot my machine.  So maybe this is not the identical problem discussed here.  Sometimes it gives the "You already have an open SSL VPN connection" warning, but not always. Either way, it stops at 98%, after a minute or so, it just clears the login fields of the forticlient window as if nothing had ever happened.
 
Rebooting my machine "resets" something and makes connection possible.  But this is a frustrating workaround.  
 
Is there a process or service I should be able to restart that would have the same effect as rebooting?
#66
ss198939@gmail.com
Bronze Member
  • Total Posts : 35
  • Scores: 2
  • Reward points: 0
  • Joined: 2016/01/26 05:12:04
  • Status: offline
Re: VPN stuck at status 98% 2016/01/27 21:04:05 (permalink)
0
I have also faced this issue.
This is problem with window. If u will use same client in another window it will work. My problem.was resolved by formating window.

And also check.if u r using right version of client.check in support.fortinet.com.
#67
adnan
New Member
  • Total Posts : 2
  • Scores: 0
  • Reward points: 0
  • Joined: 2016/01/28 04:55:00
  • Status: offline
Public IP mapping for VPN clients 2016/01/28 04:57:47 (permalink)
0
Dear,

We are having problem regarding VPN authentication. Due to security concern, we request our client to purchase public IP from any vendor (DSL, Fiber etc). After taking public IP information from client, our team will bind this public IP for VPN connectivity so that authentic user can connect (who has public IP).
 
 
#68
a.tallone@oliocarli.it
New Member
  • Total Posts : 2
  • Scores: 0
  • Reward points: 0
  • Joined: 2016/02/28 02:16:23
  • Status: offline
Re: Public IP mapping for VPN clients 2016/02/28 02:22:07 (permalink)
0
Hi everyone!
 
I'm having the same issue (stuck 98%) but apparently all ok about network devices. 
 
Version 5.4.0.0780
 
Here's my log:
 
28/02/2016 11:08:17 Warning Console id=96870 user=alby msg="Logs were cleared"
28/02/2016 11:08:20 Notice VPN id=96573 user=alby msg="VPN before logon was disabled" vpntype=ipsec
28/02/2016 11:08:20 Notice ESNAC id=96951 user=alby msg="Endpoint control policy synchronization was enabled"
28/02/2016 11:08:20 Notice Console id=96880 user=alby msg="User disabled WAN Acceleration"
28/02/2016 11:08:20 Warning SSOMA id=96982 user=alby msg="Single Sign-On Mobility Agent was disabled"
28/02/2016 11:08:20 Warning Console id=96840 user=alby msg="Fortiproxy is disabled"
28/02/2016 11:08:20 Debug Scheduler GUI change event
28/02/2016 11:08:22 Debug Config Comments removed from (C:\Users\alby\AppData\Local\Temp\tmp_connect_fct.cnf)
28/02/2016 11:08:22 Debug Scheduler GUI change event
28/02/2016 11:08:22 Debug ESNAC PIPEMSG_CMD_ESNAC_STATUS_RELOAD_CONFIG
28/02/2016 11:08:22 Debug ESNAC PIPEMSG_CMD_ESNAC_STATUS_UPDATE_PREFERRED_FGT
28/02/2016 11:08:24 Debug Scheduler GUI change event
28/02/2016 11:08:24 Debug Update Update task is called with dwSession=-1
28/02/2016 11:08:24 Debug Update forticlient.fortinet.net
28/02/2016 11:08:24 Debug Update start_update_thread() called
28/02/2016 11:08:24 Debug Update Impersonated=0
28/02/2016 11:08:24 Debug Update update started...
28/02/2016 11:08:24 Debug Update update process sending request: 00000000FSCI00000000000000000000
28/02/2016 11:08:24 Debug Update update process sending request: 00000000FDNI00000000000000000000
28/02/2016 11:08:24 Debug Update update process sending request: 01000000FECT00000000000000000000
28/02/2016 11:08:24 Debug Update update process sending request: 05004000FVEN00800054009999999999
28/02/2016 11:08:24 Debug Update update process sending request: 05004000FCBN00000000009999999999
28/02/2016 11:08:24 Debug Update updatetask get virus info file failed
28/02/2016 11:08:25 Debug Update update process received object(1 of 3): FCPR
28/02/2016 11:08:25 Debug Update update process received object(2 of 3): FDNI
28/02/2016 11:08:25 Debug Update update process received object(3 of 3): FECT
28/02/2016 11:08:25 Debug Update update done
28/02/2016 11:08:25 Debug Scheduler FortiTrayApp : Received WM_USER_UPDATE_SUCCESS message, lParam=0x1
28/02/2016 11:08:25 Debug Update update thread exit
28/02/2016 11:08:25 Debug Update No update is available.
28/02/2016 11:08:25 Debug Scheduler GUI change event
28/02/2016 11:08:28 Debug Scheduler handle_processtermination() called
28/02/2016 11:08:28 Debug Scheduler child process terminates normally
28/02/2016 11:08:28 Debug Scheduler handle_processtermination() called
28/02/2016 11:08:28 Debug Scheduler child process terminates normally
28/02/2016 11:08:31 Debug ESNAC dwSilentReg false
28/02/2016 11:08:31 Debug ESNAC bFirstKA true
28/02/2016 11:08:31 Debug ESNAC Start searching for FGT
28/02/2016 11:08:31 Debug ESNAC Searching Default GW
28/02/2016 11:08:32 Debug ESNAC Timeout in select in SocketConnect
28/02/2016 11:08:32 Debug ESNAC Socket connect failed
28/02/2016 11:08:32 Debug ESNAC 192.168.1.1:8013, Secondary - 0
28/02/2016 11:08:32 Debug ESNAC End searching for FGT
28/02/2016 11:08:33 Debug VPN FortiSslvpn: 7376: fortissl_disconnect() called
28/02/2016 11:08:35 Debug VPN FortiSslvpn: 7376: tunnel_close() called
28/02/2016 11:08:35 Debug VPN FortiSslvpn: 7376: sock_close() called:-1
28/02/2016 11:08:35 Debug VPN FortiSslvpn: SSL VPN Tunnel is Disconnected *********
28/02/2016 11:08:35 Debug VPN FortiSslvpn: Broken pipe! Client is exited (2) - Disconnect.
28/02/2016 11:08:35 Debug VPN FortiSslvpn: 7376: fortissl_disconnect() called
28/02/2016 11:08:35 Debug VPN FortiSslvpn: Init:ConnectNamedPipe(): Wait(hEventOverLapped) OK.
28/02/2016 11:08:35 Debug VPN FortiSslvpn: before ConnectNamedPipe
28/02/2016 11:08:35 Debug VPN FortiSslvpn: Init:ConnectNamedPipe(): rc=0, err=997
28/02/2016 11:08:35 Debug VPN FortiSslvpn: _ReceiveMessage: (000003E8)
28/02/2016 11:08:37 Debug VPN FortiSslvpn: 7376: tunnel_close() called
28/02/2016 11:08:37 Debug VPN FortiSslvpn: 7376: sock_close() called:-1
28/02/2016 11:08:37 Debug VPN FortiSslvpn: SSL VPN Tunnel is Disconnected *********
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7500: fortissl_setconfig() called
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7500: fortissl_setconfig() connectionName:work
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7500: fortissl_setconfig() called
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7500: fortissl_setconfig() cookie: c3nCv6lcKLf9dF1PBcT8Z4h07JFm7PTOFWpz/WQmU5978WELGbZlng5osAKxMMpi%0aldnwoMbmuqlO7HA1G/FIn6D2bGl0eTupZUb7E+gxwqNK9fn8cev3V0M2gGv174ju%0a1zu2YMpkwoRVBS0RGbKww9l/ZGgMNm1Oxi3Mccj87HRaK6fOA/Q52IzzM5a8Eb9B%0aK2I/GiYSiYyzkQhApx2gNQ==%0a
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7500: fortissl_setconfig() hostname:vpn.oliocarli.it port:10443
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7500: fortissl_setconfig() called
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7500: fortissl_setconfig() splittunnel info:172.16.1.11/255.255.255.255,172.16.1.38/255.255.255.255,172.16.1.20/255.255.255.255,172.16.1.14/255.255.255.255,172.16.1.25/255.255.255.255,172.16.0.0/255.255.0.0,172.17.20.0/255.255.255.0
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7500: fortissl_setconfig() called
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7500: fortissl_setconfig(): reset proxy
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7500: fortissl_setversion() called:1
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7500: fortissl_connect() called. (ipv6=0, fct=1)
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7500: Resolve server 'vpn.oliocarli.it(10443)' = 213.204.2.2:10443/[0000:0000:0000:0000:0000:0000:0000:0000]:0.
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7500: Setting route to 213.204.2.2
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7500: on 192.168.1.1
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7500: get_interface_metric() called, local index:6
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7500: metric: 10
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7500: CreateIpForwardEntry(dest=0202ccd5 mask=ffffffff next=0101a8c0)
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7500: [D]IPv4SetRouteToFgt(00B4380C, 00B4384C)=0
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: tunnel_thread() called
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7508: ras_thread() called
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: * tunnel opened
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: SSL authentification using files: C:\Program Files (x86)\Fortinet\FortiClient\fortisslcacert.pem C:\Program Files (x86)\Fortinet\FortiClient\fortisslclient.crt C:\Program Files (x86)\Fortinet\FortiClient\fortisslclient.key
28/02/2016 11:08:38 Debug VPN (repeated 1 times in last 0 sec) FortiSslvpn: 7620: SSL authentification using files: C:\Program Files (x86)\Fortinet\FortiClient\fortisslcacert.pem C:\Program Files (x86)\Fortinet\FortiClient\fortisslclient.crt C:\Program Files (x86)\Fortinet\FortiClient\fortisslclient.key
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: * SSL OK
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: * tunnel pending ...
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: info: tunnel_start_to_fgt(00B33F80) called.
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: connecting tunnel (0) ...
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: connecting TCP ...
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: TCP_NODELAY value:1
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: [D]WSAConnect(1,0), r=-1, e=10035.
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: Socket event signaled!
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: connecting SSL ...
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: call back called!
28/02/2016 11:08:38 Debug VPN (repeated 2 times in last 0 sec) FortiSslvpn: 7620: call back called!
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: SSL connected
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: [DoXmlConfig]...
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: info: SslBlockingWrite(00B9A020, 02046E90, 303, 10000) called.
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: [DoXmlConfig]: GET remote/fortisslvpn_xml ... (send 303 of 303 bytes): GET /remote/fortisslvpn_xml HTTP/1.1 Host: sslvpn Cookie: SVPNCOOKIE=c3nCv6lcKLf9dF1PBcT8Z4h07JFm7PTOFWpz/WQmU5978WELGbZlng5osAKxMMpi%0aldnwoMbmuqlO7HA1G/FIn6D2bGl0eTupZUb7E+gxwqNK9fn8cev3V0M2gGv174ju%0a1zu2YMpkwoRVBS0RGbKww9l/ZGgMNm1Oxi3Mccj87HRaK6fOA/Q52IzzM5a8Eb9B%0aK2I/GiYSiYyzkQhApx2gNQ==%0a ---- .
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: info: SslBlockingRead(00B9A020, 02044E18, 8191, 10000) called.
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: [DoXmlConfig]: GET remote/fortisslvpn_xml ... (received 1169 bytes): HTTP/1.1 200 OK Date: Sun, 28 Feb 2016 10:08:40 GMT Set-Cookie: SVPNCOOKIE=c3nCv6lcKLf9dF1PBcT8Z4h07JFm7PTOFWpz/WQmU5978WELGbZlng5osAKxMMpi%0aldnwoMbmuqlO7HA1G/FIn6D2bGl0eTupZUb7E+gxwqNK9fn8cev3V0M2gGv174ju%0a1zu2YMpkwoRVBS0RGbKww+ubPNURQrBdgHp7RrW1R/Dk5YDZGLGaRqs5KjPpvUmS%0am/wtv0BJrYvYjyJShF2aDA==%0a; path=/; secure; httponly Transfer-Encoding: chunked Content-Type: text/xml X-Frame-Options: SAMEORIGIN <?xml
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: [DoXmlConfigEx]: Xml= <?xml version='1.0' encoding='utf-8'?><sslvpn-tunnel ver='1'><fos platform='FG200B' major='5' minor='02' patch='6' build='0711' branch='711' /><client-config save-password='off' keep-alive='off' auto-connect='off' /><ipv4><dns ip='172.16.1.38' /><dns ip='172.16.1.20' /><assigned-addr ipv4='192.168.127.1' /><split-tunnel-info><addr ip='172.16.1.11' mask='255.255.255.255' /><addr ip='172.16.1.38' mask='255.255.255.255' /><addr ip='172.16.1.20' mask='255.255.255.255' /
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: [DoXmlConfig]: dnsSuffixes =
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: [DoLicCheck]...
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: info: SslBlockingWrite(00B9A020, 02046E90, 751, 10000) called.
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: [DoLicCheck]: GET /remote/licensecheck ... (usr=tallonea@carli, send 751 of 751 bytes): GET /remote/licensecheck HTTP/1.1 Host: sslvpn Cookie: SVPNCOOKIE=c3nCv6lcKLf9dF1PBcT8Z4h07JFm7PTOFWpz/WQmU5978WELGbZlng5osAKxMMpi%0aldnwoMbmuqlO7HA1G/FIn6D2bGl0eTupZUb7E+gxwqNK9fn8cev3V0M2gGv174ju%0a1zu2YMpkwoRVBS0RGbKww9l/ZGgMNm1Oxi3Mccj87HRaK6fOA/Q52IzzM5a8Eb9B%0aK2I/GiYSiYyzkQhApx2gNQ==%0a FCC_License: 5645523D310A4643545645523D352E342E302E303738300A5549443D464530383138344437303843343534344136
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: info: SslBlockingRead(00B9A020, 02043E10, 8191, 10000) called.
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: [DoLicCheck]: GET /remote/licensecheck ... (received 659 bytes): HTTP/1.1 200 OK Date: Sun, 28 Feb 2016 10:08:40 GMT FCC_Status: 10 FCC_Message: 5645523d310a434f44453d300a Transfer-Encoding: chunked Content-Type: text/html X-Frame-Options: SAMEORIGIN <html> <head> <meta http-equiv="Content-Type" content="text/html; charset=utf-8"> <meta http-equiv="Pragma" content="no-cache"> <meta http-equiv="cache-control" content="no-cache"> <meta http-equiv="cache-control" content="must-rev
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: [DoLicCheck]: After DecodeLicenseResult(): s=10, r=0, message= 5645523d310a434f44453d300a VER=1 CODE=0 ----
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: ===>send to login, ret=331 buf=GET /remote/sslvpn-tunnel?dns0=192.168.1.1&dns1=8.8.4.4 HTTP/1.1 Host: sslvpn Cookie: SVPNCOOKIE=c3nCv6lcKLf9dF1PBcT8Z4h07JFm7PTOFWpz/WQmU5978WELGbZlng5osAKxMMpi%0aldnwoMbmuqlO7HA1G/FIn6D2bGl0eTupZUb7E+gxwqNK9fn8cev3V0M2gGv174ju%0a1zu2YMpkwoRVBS0RGbKww9l/ZGgMNm1Oxi3Mccj87HRaK6fOA/Q52IzzM5a8Eb9B%0aK2I/GiYSiYyzkQhApx2gNQ==%0a
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: info: ssl_connect -> Set XmlConfig OK.
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7620: info: tunnel_up(00B33F80, 1) called.
28/02/2016 11:08:39 Debug VPN FortiSslvpn: 7508: info: ras_loop(), XmlConfig OK.
28/02/2016 11:08:39 Error VPN FortiSslvpn: 7508: RasGetEntryDialParams returns 1058 :
28/02/2016 11:08:40 Debug VPN FortiSslvpn: 7640: monitor_thread() called
28/02/2016 11:08:40 Debug VPN FortiSslvpn: 7640: register_route_change_event_ipv4() called
28/02/2016 11:08:40 Debug VPN FortiSslvpn: 7640: ras_thread quit
28/02/2016 11:08:40 Error VPN FortiSslvpn: 7500: failed to create one of the threads
28/02/2016 11:08:40 Debug VPN FortiSslvpn: g_dwKeepRunningFlag = 0.
28/02/2016 11:08:40 Debug VPN FortiSslvpn: 7640: waiting for tunnel thread ...
28/02/2016 11:08:44 Debug VPN FortiSslvpn: 5232: fortissl_getstatus(2049) called
28/02/2016 11:08:44 Debug VPN FortiSslvpn: 7640: stopping tunnel thread
28/02/2016 11:08:44 Debug VPN FortiSslvpn: 7640: tunnel_close() called
28/02/2016 11:08:44 Debug VPN FortiSslvpn: 7640: sock_close() called:1032
28/02/2016 11:08:44 Debug VPN FortiSslvpn: 7640: Monitor thread terminated
28/02/2016 11:08:44 Debug VPN FortiSslvpn: 7640: RestartDnschcheService() -> (tid=6180)
28/02/2016 11:08:44 Debug VPN FortiSslvpn: 6180: RestartDnscacheServiceProc() running ...
28/02/2016 11:08:44 Debug VPN FortiSslvpn: 6180: RestartDnscacheServiceProc()->QueryServiceStatus(3): ss=1
28/02/2016 11:08:46 Debug VPN FortiSslvpn: 6180: RestartDnscacheServiceProc() end.
28/02/2016 11:08:51 Debug ESNAC dwSilentReg false
28/02/2016 11:08:51 Debug ESNAC bFirstKA true
28/02/2016 11:08:51 Debug ESNAC Start searching for FGT
28/02/2016 11:08:51 Debug ESNAC Searching Default GW
28/02/2016 11:08:52 Debug ESNAC Timeout in select in SocketConnect
28/02/2016 11:08:52 Debug ESNAC Socket connect failed
28/02/2016 11:08:52 Debug ESNAC 192.168.1.1:8013, Secondary - 0
28/02/2016 11:08:52 Debug ESNAC End searching for FGT
 
post edited by a.tallone@oliocarli.it - 2016/02/28 04:39:25
#69
fabianp
New Member
  • Total Posts : 5
  • Scores: 0
  • Reward points: 0
  • Joined: 2016/03/31 04:11:23
  • Status: offline
Re: Public IP mapping for VPN clients 2016/03/31 04:14:09 (permalink)
0
Hi Everybody.
 
I've got the same issue on my Microsoft Surface Book W10 Client. Is there any solution to this problem?
 
For me, I can reinstall the Fortinet Client on my device and work for around one week without problems. But after some point I can't connect until I reinstall the client on my device.
 
Thank you and best regards
Fabian
#70
fabianp
New Member
  • Total Posts : 5
  • Scores: 0
  • Reward points: 0
  • Joined: 2016/03/31 04:11:23
  • Status: offline
Re: Public IP mapping for VPN clients 2016/04/20 00:47:36 (permalink)
0
Hi
 
Still no Feedback from Fortinet or other solutions? It's been months now...
I know the workaround to get the VPNClient working again, but that's just a frustrating problem of this client and with issues like this, we can't use it with customers!
 
Regards
Fabian
#71
netmin
Gold Member
  • Total Posts : 209
  • Scores: 22
  • Reward points: 0
  • Joined: 2013/11/28 13:49:12
  • Location: NE, Germany
  • Status: offline
Re: Public IP mapping for VPN clients 2016/05/03 14:11:53 (permalink)
0
While it may or may not apply to each situation but is seen under certain conditions, I would double check two addl. things if it was not already part of any previous workaround:
 
a) excessive amount of phantom network devices (hidden + non-present [meaning: previously connected])
 - start a cmd 'as administrator' (i.e.: Start->type: cmd -> Ctrl+Shift+Enter)
 - in this admin-cmd enter: set devmgr_show_nonpresent_devices=1
 - then enter: devmgmt.msc
 - in the device manager window that gets opened: enable the display of hidden devices from the menu
  (phantoms visually differentiate from 'default' hidden devices as they show up more in gray but there's no general rule that you can just delete all of them without risk (i.e. some may become phantoms due to hardware Wifi/Bluetooth/WWAN switches being disabled, etc. so it is rather an indicator if you are not familiar with it or ... you have a good backup ).
 
b) try to rule out the other usual suspects (isatap, 6to4, teredo) if not in use:
 - from the admin-cmd:
   netsh int isatap set state disabled
   netsh int teredo set state disabled
   netsh int 6to4 set state disabled
(the default state is 'default')
 
After this it may require a reboot, depending on the condition the VPN client is in. Once again: it may not apply to each error situation but is worth a try.
#72
scerazy
Gold Member
  • Total Posts : 193
  • Scores: 2
  • Reward points: 0
  • Joined: 2009/12/22 14:09:01
  • Status: offline
Re: Public IP mapping for VPN clients 2016/06/11 03:52:54 (permalink)
0
On a completely buggered machine, Option 3 from above thread #65 worked perfectly fine
 
Seb
#73
fabianp
New Member
  • Total Posts : 5
  • Scores: 0
  • Reward points: 0
  • Joined: 2016/03/31 04:11:23
  • Status: offline
Re: Public IP mapping for VPN clients 2016/07/05 02:40:43 (permalink)
0
Hi,
 
I already tried all these solutions but still get the 98%error from time to time. The only temporary solution is a reboot of the Client. Is there any timeline, until Forti has this issue fully solved in a new VPNClient?
 
Thanks and best regards
Fabian
#74
MikePruett
Platinum Member
  • Total Posts : 702
  • Scores: 17
  • Reward points: 0
  • Joined: 2014/01/08 19:39:40
  • Location: Montgomery, Al
  • Status: offline
Re: VPN stuck at status 98% 2016/07/05 07:28:43 (permalink)
0
Fabian,
 
We have this issue off and on as well. My SE's and TAC's have not been able to determine a root cause for our solution. We have to try a mixture of the previously mentioned solutions in order to resolve.
 
It is annoying but at least there is a "work around". Hopefully a solution appears soon.
#75
torenhof
New Member
  • Total Posts : 11
  • Scores: 0
  • Reward points: 0
  • Joined: 2015/05/05 08:17:44
  • Status: offline
Re: VPN stuck at status 98% 2016/07/20 02:54:08 (permalink)
0
Hello,
 
I've been experiencing this on Win 8.0
The KB: http://kb.fortinet.com/kb/documentLink.do?externalID=FD36630
solved the issue.
 
Regards
Gerrit
#76
pimu
New Member
  • Total Posts : 1
  • Scores: 0
  • Reward points: 0
  • Joined: 2016/08/09 02:49:54
  • Status: offline
Re: VPN stuck at status 98% 2016/08/10 06:32:02 (permalink)
0
Hi
I just experience on my Windows 10 all what greylander says (see #66 above).
I see all what he says to see, except the "You already have an open SSL VPN connection" warning, and I agree with him about the annoying workaround of restarting the machine
 
I would only add that I see often DNS not working after disconnection and what I see in the log of forticlient during the minute of wait before timeout:
..
15:21:44     Debug   VPN     FortiSslvpn: 15092: poll_recv_ssl -> SSL_ERROR_WANT_READ
15:21:44     Debug   VPN     FortiSslvpn: 15092: poll_recv_ssl return 0 bytes, read after timeout
15:21:44     Debug   VPN     FortiSslvpn: 15092: [tunnel_loop_read_socket] wait for socket event
15:21:44     Debug   VPN     FortiSslvpn: 15092: wait for socket event timeout, try to do a read
15:21:44     Debug   VPN     FortiSslvpn: 15092: [SSL-IN] buf size = 65540, ptr = 0, space = 65540
15:21:44     Debug   VPN     FortiSslvpn: 15092: [SSL-IN] len = -1
15:21:44     Debug   VPN     FortiSslvpn: 15092: poll_recv_ssl -> SSL_ERROR_WANT_READ
..
 
Regards
P.
#77
FatalHalt
Gold Member
  • Total Posts : 124
  • Scores: 8
  • Reward points: 0
  • Joined: 2014/06/11 08:51:54
  • Status: offline
Re: VPN stuck at status 98% 2016/08/16 08:52:04 (permalink)
0
Can anyone at Fortinet weigh in on the progress on a permanent solution for this? I understand this is a complex issue that needs to be resolved jointly / working with Microsoft, but I also think 2 years is a bit of a joke.
 
I don't really care what the update is, I would just love to know that there is one, and that Fortinet would value its customers enough to give us some sort of update, even if the update is that it won't be fixed until Windows X, or whatever. 
#78
fabianp
New Member
  • Total Posts : 5
  • Scores: 0
  • Reward points: 0
  • Joined: 2016/03/31 04:11:23
  • Status: offline
Re: VPN stuck at status 98% 2016/09/27 00:07:01 (permalink)
0
Still no progress with this issue? Some customers use now other VPN solutions, exactly because of this...
#79
ITGuy11
New Member
  • Total Posts : 17
  • Scores: 0
  • Reward points: 0
  • Joined: 2016/03/28 06:29:50
  • Status: offline
Re: VPN stuck at status 98% 2016/10/03 12:09:04 (permalink)
0
One of my users just ran into this issue a few days ago.  Very annoying having to uninstall/reinstall FortiClient just to get the SSL VPN connection to work...
#80
Page: < 12345 > Showing page 4 of 5
Jump to:
© 2020 APG vNext Commercial Version 5.5